r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: anticheat not loading
Pages: [1]
Print
Author Topic: anticheat not loading  (Read 10677 times)
TeLtRoN
Guest
« on: September 23, 2008, 09:05:37 pm »

Hello

Same problem here. Sometimes connect without troubles, but others appears the error. I set timescale "0" but it doesn,t work. I don,t think my AV block the .dll.

Thank you for your time, sorry for me english.

bye.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: September 23, 2008, 11:42:33 pm »

The "timescale is cheat protected" message is just a side effect of certain cheat checks coming from the server, it is not actually a problem. If anticheat is failing to load, then that is something else, almost always an anti-virus problem. What is the error you are getting?
Logged
TeLtRoN
Guest
« Reply #2 on: September 24, 2008, 08:49:50 pm »

The complete message is " This server requires the r1ch.net anticheat module". I got the module, and works without troubles till some days ago. Please tell me if you need more information.

TY
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #3 on: September 24, 2008, 10:57:07 pm »

That means the anticheat.dll is not loading properly for some reason. Check the anticheat.dll is in your Q2 folder and that your Q2 folder is added to exceptions on any antivirus or other scanning software.
Logged
Teltron
Guest
« Reply #4 on: September 25, 2008, 08:34:13 pm »

The dll file is in the folder and added the q2 folder to the exceptions, but still doesn,t work. I don,t know why now start the problems, because i have played normally since i got the module nearly a year ago. I also download again the files and updated them , but no solution.

TY
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #5 on: September 25, 2008, 08:38:04 pm »

What anti virus software do you use, and it is possible to temporarily turn it off?
Logged
Teltron
Guest
« Reply #6 on: September 26, 2008, 06:45:03 pm »

The AV is NOD32 and turned off the process, but it doesn,t work.
Logged
Teltron
Guest
« Reply #7 on: September 27, 2008, 07:42:14 pm »

I think i solved the problem.

Some days ago when i turn on the pc appeard a message " Cmos Error - Setup " , need to press f1 to load de default values and continue the process, i think i need to change a battery inside. The clock on the systray change the hour, never fixed this because it will change when i turn off the pc. But today change the hour to the correct one, try to connect to the server and it works.

Question.. Make senses what it happened? i can,t relation the problem with the solution, if that is the solution

ty for all!!
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #8 on: September 28, 2008, 01:03:27 am »

Yes, that makes sense. Anticheat uses a certificate to authenticate the anticheat server, and this certificate is only valid from a certain date. If your clock is not set properly then the client will reject the certificate and fail to connect.
Logged
mhanor
Member

Posts: 120


« Reply #9 on: September 28, 2008, 02:12:45 am »

it could be useful to some people if you added that info to FAQ / Common Problems, on antiche.at (at least there)
I personally didn't knew about the date requirement until now, although I do maintain the correct date on my PCs
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: anticheat not loading
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines