r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: 2 wierd error messages
Pages: [1]
Author Topic: 2 wierd error messages  (Read 6653 times)
« on: March 04, 2005, 10:15:27 am »

I'm running the latest version of R1Q2 on my Quake 2 WoD server.  Last night we were playing in the server and we all got the phone jack.  This happened 2 times within 15 minutes.  The server restarted itself after about 45 seconds both times.  Here is the error message:

Bad SV_Trace: 1000 calls in a single frame        ABORT!!!

There was, at the time, a new player in the server that had not shown up before.  After he disconnected, I kept getting the next error message over and over again on the server console:

Game Error:  PF_centerprintf to disconnected client  4, ignored.

What do these error messages mean?  Is this something that needs to be addressed?

Also, while I'm here;  Here is another error I got awhile ago when all players got kicked from the server at the same time:

"Speed Hack".  All 7 of us got booted.  We reconnected and after that we were randomly booted for the next 10 minutes.  I've read up on this false positive and it had something to do with "set sv_enforcetime".  At the time, I had it set to "0".  Since then, I've tried different values.  At the time I got the Bad SV_Trace error, I think I had set the value abnormally high (50) to see if it made a difference.  If the value was set to 0, then it should have been disabled.

Here is my present server.cfg setup concerning R1Q2:

// R1Q2 settings
// www.r1ch.net/forum/viewtopic.php?t=103
set sv_locked 0
set sv_restartmap q2dm1
set sv_password ""
set sv_filter_q3names 0
set sv_filter_userinfo 0
set sv_filter_stringcmds 0
set sv_blackholes 1
set sv_allownodelta 0
set sv_deny_q2ace 1
set sv_iplimit 10
set sv_connectmessage ""
set sv_nc_visibilitycheck 1
set sv_nc_clientsonly 1
set sv_max_download_size 0
set sv_max_netdrop 20
set sv_hidestatus 0
set sv_hideplayers 0
set sv_fpsflood 0
set sv_randomframe 0
set sv_gamedebug 1
set sv_msecs 1800
set sv_recycle 0
set sv_nc_kick 15
set sv_nc_announce 128
set sv_filter_nocheat_spam 0
set sv_uptime 0
// b1621+
set sv_strafejump_hack 1
set sv_reserved_slots 0
set sv_reserved_password ""
set sv_allow_map 1
set sv_allow_unconnected_cmds 1
// b1873+
set sv_strict_userinfo_check 1
set sv_calcpings_method 2
// b1950+
set sv_no_game_serverinfo 0
// b2742+
set sv_mapdownload_denied_message ""
set sv_mapdownload_ok_message ""
set sv_max_traces_per_frame 10000
set sv_ratelimit_status 15
set sv_new_entflags 0
set sv_validate_playerskins 1
set sv_idlekick 0
set logfile_timestamp 1
set logfile_timestamp_format "%a %d %b %Y %H:%M"
// b2746+
set logfile_name "qconsole.txt"
// b4025+
set lrcon_password ""
set sv_force_reconnect "oafman.ath.cx:27910"
set sv_download_refuselimit 0
set sv_download_drop_file ""
set sv_download_drop_message ""
set sv_packetentities_hack 2
set sv_gamedebug 0
set sv_enforcetime 25
set log_filterlevel 0
// b4186+
set z_buggygame 1
// b4357+
set sv_blackhole_mask 32
set sv_entity_inuse_hack 1

Any help with these issues would be greatly appreciated.  I've done my best to scour this entire forum for answers.  If you require any further info, I'll be more than happy to oblige.  Thanks!  -Oaf{WoD}

Server:  333MHz P2 w/512 RAM running WinXP Pro.  Quake 2 WoD mod version 8.0.  Game server is the only thing running on this box.
« Reply #1 on: March 04, 2005, 10:18:42 am »

I'm sorry.  The server box is running Win 2000 Pro, not XP Pro.  -Oaf

Posts: 2625

« Reply #2 on: March 04, 2005, 11:46:09 am »

R1Q2 won't kick for "speed hack", something else such as WOD or Q2admin is doing that, possibly because it's internal timing has been thrown off due to the server freezes as a result of the bad traces. The 'Bad SV_Trace' is caused by a bug in the mod you are running and would previously have frozen the server if you were not using R1Q2. If it's taking too long for R1Q2 to notice the infinite loop and break out, you can try reducing sv_max_traces_per_frame to perhaps 1000 or so. The 'Game Error:  PF_centerprintf to disconnected client  4, ignored.' also indicates a bug in the mod that would likely crash the server if you weren't using R1Q2.
« Reply #3 on: March 04, 2005, 11:11:54 pm »

OK.  First I want to explain that I meant "Is there something I, as a server admin, need to address in my serverconfig settings".  I didn't mean it the way I typed it.  I made it sound like I was reporting a bug in R1Q2.  R1Q2 is a fantastic life-saver of a proggie and I'm very happy that you've taken the time to better this old game!

I also failed to mention that I am running Q2Admin 1.17 with the fixed .dll file you put out.  I have been running a Q2 WoD server (with Q2admin) off and on for the last 6 years and I've only come across server crashes when someone tried to vote for a map that wasn't there or was buggered up.  I've never seen these errors before and I was looking for some insight as to what parts of Q2admin.txt or the R1Q2 configs I could change to prevent this from happening.

I will send our Mod programmer the info you gave in your post and see if I can rattle his cage.  I'll also try the fix you mentioned and see if it helps.  I'll also look in Q2admin.txt and try to track down what else could be the issue but I'm no good at deciphering buggered settings.  If you have any ideas on what I should look for, I'd be more than happy.  Thanks for your expedient reply!  -Oaf
« Reply #4 on: March 04, 2005, 11:13:50 pm »

grrrrrr, always forgetting pertinent info.....  I am not currently using 3.21.  Using Q2 ver. 3.20.
Pages: [1]
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: 2 wierd error messages
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines