r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: 5920/30 Linux Server - slight problems
Pages: [1]
Print
Author Topic: 5920/30 Linux Server - slight problems  (Read 6401 times)
spliff
Member

Posts: 6


« on: October 24, 2005, 10:57:46 am »

G'day

First, I would just like to say wd Rich on all of the work that you have put into writing R1Q2. in fact, we like it so much that we use it on every Q2 server (Linux) that we run - and were really chuffed to find out that 5920 (and 5930) works with OSP much better than ver 5510 did Smiley Having said that though, with vers 5920 as well as  5930, we've noticed that there is still one minor problem as well as a couple of not-so-minor (so not major) annoyances with OSP:

Minor Problem: In OSP, one is able to bring up the player score list during a game (i.e. "scores") and an arrow appears which can be used to select a player via the square bracket keys (so like a lot of Q2 menus) and when a player is selected, one can view their stats (efficiency for each weapon used etc) in realtime. With R1Q2, that functionality is now gone.

Not-So-Minor-Problem #1: OSP and Logging: With OPS, one can configure it to either write to the logs continuously as it were or to flush the log entries that are stored in memory to disk at the end of a map. We also run Gladiator bots on the OPS server (they have to be voted in though) and OSP can be configured to either log or to not log bots kills and deaths. However, with R1Q2 seems to ignore or override OSP in both of these areas as logging is always done in realtime as it were and bot kills and deaths are also always logged - irrespective of what is in the OSP config file.

Not-So-Minor-Problem #1: Demos: Wink Players who use non R1Q2 clients (including myself - I still use the icculus.org port) such as q2advance etc have found that while playing on a server that is running ver 5920/30 and recording a demo, upon playing back the demo. the POV is sometimes sideways and other times backwards and when the player in the demo has been fragged, upon their respawning, the sideways/backwards POV remains but also, the view is heavily tilted at around 45 degrees or so. I've tried running the q2dc converter on my demos, but it simply aborts with this message:

WARNING: Wrong protocol version (not a r1q2 demo file?)

which is not suprising seeing as all of our non-r1q2 clients use protocol 34 (I can see what protocol is being used by each client via the rcon "status" command).

So, any suggestions/tips - especially in regards to the 3rd point - would be greatly appreciated.

Cheers.



Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: October 24, 2005, 12:13:08 pm »

I don't know why your mod would suddenly stop reading your settings, but it is unlikely that R1Q2 would have anything to do with it. As for the demos, check your sv_optimize_deltas setting - setting higher than 1 will break demo compatibility. I'll look into these issues some more once Wilma is out of the way and I don't risk losing power.
Logged
spliff
Member

Posts: 6


« Reply #2 on: October 24, 2005, 09:53:06 pm »

I don't know why your mod would suddenly stop reading your settings, but it is unlikely that R1Q2 would have anything to do with it. As for the demos, check your sv_optimize_deltas setting - setting higher than 1 will break demo compatibility. I'll look into these issues some more once Wilma is out of the way and I don't risk losing power.

Well, the mod hasn't suddenly stopped reading my settings. It appears to read and process all of them with the sole exception being those as regards logging. I'll double check though using ye olde id binary and let you know what happened.

P.S. Setting sv_optimize_deltas to 1 solved the demo problem. Cheers. Smiley
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: 5920/30 Linux Server - slight problems
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines