r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Which mods are working with r1q2serv ????
Pages: 1 [2]  All
Print
Author Topic: Which mods are working with r1q2serv ????  (Read 12400 times)
Bossman
Member

Posts: 486


« Reply #15 on: March 22, 2005, 07:53:08 am »

go here


http://www.planetquake.com/motw/expert.shtm

I don't know if it is the right version but it got the info for your mod. downlod and use the reeadme file....And the gamei386.so file get it and try it. and stuff..
Logged
Zearth
Member

Posts: 18


« Reply #16 on: March 22, 2005, 06:50:43 pm »

http://www.planetquake.com/lithium
Logged
[OPi]Killer
Member

Posts: 9


« Reply #17 on: March 23, 2005, 12:56:29 am »

I have the lastest version of Lithium II mod (1.24) for linux, but don't work:]
Logged
Bossman
Member

Posts: 486


« Reply #18 on: March 23, 2005, 09:04:14 am »

 So get a new file and try it out and see if it still does whatever. But If I was you I would just reload the whole mod cause if you had them 2 mixed up in your baseq2 dir you might be using the gamei386.so file from the battle mod since that one worked and the other one didn't. That is what I seen from your post in the beginning that it says the files for both mods are in same dir. then baseq2 dir. You can do that if you change names and stuff but you can also mess up and then it would overwrite. On Linux from ftp if you change name it will do that. But if you have a file with that name already.....Cya its gone. It don't ask when you change name only if you upload a file with same name does it ask: "Are you sure you want to overwrite buddy you may fk up something???"

 See what I was saying in the beginning (And got confused too) is if you look at your post you have same set up (run file batch file or what ever it is called there) on both mods one works the other don't. ( Look at reply 4 top for Lith. server bottom for your battle one same game dir) So I think that the battle gamei386.so  is in your baseq2 dir that is why it works. Then when your try the Lithiun II mod it gets seg error because it calls up the battle gamei386.so file So if you took them put them in another dir you did that part right just that the files are for Battle not Lithium thus the reason to reinstall it and make sure you use right configs.... Open them up to look at them make sure its right mod that you are trying to get on.( especially the dedicated.cfg file since it is same name for both mods too) Do all that then try server.

  OK I don't know anything else for you. I am sure that these other guys here will help you with your configs and stuff as I am not up on all that for your mod but they are. So with that good luck and hope it works out for you. Sorry about the book guys grin
« Last Edit: March 23, 2005, 09:06:39 am by Bossman » Logged
Nick
Member

Posts: 211


« Reply #19 on: March 23, 2005, 01:49:23 pm »

There is a lot of people on the icculus mailing list (Linux quake2 build) that have the same problem with Lithium.

Here is one post in a long thread:

Code:

Re: [quake2] Lithium II - need new gamei386.so


From:
Karen Pouelle <hockeyvixen@yahoo.ca>


To:
quake2@icculus.org


Date:
Thu Feb 17 19:23:10 2005


That's the sort of thing I was ranting about earlier - great mod, no source,
no new binary releases.  If you want your mod to die, use the SDK instead of
GPL, don't release the source to anyone, and don't recompile binaries.

I've a Quake 2 mod I've been working on for a few years where the source is
GPL, but it's stuck here on my hard drive and it needs a nice home. It's been
7 months since I emailed Ryan about hosting at Icculus without a word... so,
anyone have any ideas on a good place to host Quake 2 mods, CVS and project
tools, web page, mailing list, etc?

Karen

 --- Nick Warne <nick@linicks.net> wrote:
> On Thursday 17 February 2005 05:56, m0gely wrote:
> > I have my server back up and running.  But after getting it to work on
> > FreeBSD (as described in my last thread) the Lithium II library will not
> > work.  I am pretty sure it needs to be recompiled for the same reasons I
> > had to recompile the q2 source.
> >
> > Did WhiteFang ever release the source to this plugin?  If so does anyone
> > here have it?  It's not on the Lithium II site.
> >
> > http://www.planetquake.com/lithium/
>
> ASAIK source for Lithium was never released.
>
> Nick

Nick
Logged
Snake
Member

Posts: 184


« Reply #20 on: March 23, 2005, 02:49:29 pm »

I have the lastest version of Lithium II mod (1.24) for linux, but don't work:]

Version 1.23 works. I don't know where this .so originated since I wasn't involved in the original setup  of the server, all I know is it works fine with r1q2.
Logged
[OPi]Killer
Member

Posts: 9


« Reply #21 on: March 23, 2005, 03:52:30 pm »

Bossman SpeZiallY 4U:

mv baseq2 battle
mv lith baseq2
./strart

I can't find Lithium II 1.23 for linux. Snake could you send me ( if U have iT ) or link.
killer@lo2.opole.pl
Logged
[OPi]Killer
Member

Posts: 9


« Reply #22 on: March 24, 2005, 10:55:37 am »

Great ThX snake my server is running now under r1q2 Cheesy

Why my server don't want to work with Lithium II mod?Huh
Reason:
Version 1.24 of Lithium II mod is uncompatibile with r1q2 !!!!
Logged
Pages: 1 [2]  All
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Which mods are working with r1q2serv ????
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines