r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Demos and Protocol 34
Pages: [1]
Print
Author Topic: Demos and Protocol 34  (Read 3945 times)
_DOA_MERLYN
Member

Posts: 35



« on: April 17, 2005, 03:49:27 pm »

Greetings R1CH...  I recorded a demo using R1Q2 b5240 with protocol and cl_protocol both set to 34 and I get an error when trying to export the demo to avi using BeefQuake...  here's a condump of the error as well as the demo...  there's about 25 seconds or so I want to rip out of there for a small Flash movie...  is there anything you can do to help with this?  thanks...

Code:
==== InitGame ====
------- Server Initialization -------
0 entities inhibited
0 teams with 0 entities
-------------------------------------
loopback: client_connect
********************
ERROR: SV_SendClientMessages: msglen > MAX_MSGLEN
********************
==== ShutdownGame ====

http://www.milech.com/temp/q2camp.dm2

Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: April 17, 2005, 05:28:10 pm »

Bah, looks like a another demo recording bug, the client writes out the new 4k message sizes even on cl_protocol 34. It's possible, although difficult, to fix the demo if you really need to get it playing back on a protocol 34 client.
Logged
_DOA_MERLYN
Member

Posts: 35



« Reply #2 on: April 17, 2005, 09:24:00 pm »

nah, i can alwayz just go make another one...  but is it something you can fix in an update?
Logged
_DOA_MERLYN
Member

Posts: 35



« Reply #3 on: April 17, 2005, 09:47:07 pm »

is this something i can remedy by manipulating this?

Quote
New protocol 35 netcode. Offers more bandwidth savings by making best use of otherwise-unused bits in the data stream. Allows large (fragemented) UDP packets, "disabled" (uses traditional packet size) by default since some consumer routers suck and can't reassemble properly. Use net_maxmsglen to control the maximum packet size - clients can choose what they want to use by setting this, a server can allow/disallow it by also changing this to the maximum they want to accept. Defaults to 1390 - the default protocol 34 message size. Set to 0 to allow the maximum new default packet size (4086 bytes). If you have problems connecting as a client, set this back to 1390. See http://r-1.ch/r1q2-protocol.txt for details of the current implementation of protocol 35. **bug** don't set net_maxmsglen to 0 on a server in this build. Use 4086 if you wish to enable the new larger packets for now.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #4 on: April 17, 2005, 10:44:55 pm »

No, protocol 34 is always limited to 1390 regardless. It's a bug and will be fixed next build.
Logged
_DOA_MERLYN
Member

Posts: 35



« Reply #5 on: April 17, 2005, 11:22:15 pm »


ahh ok, thanks...  cool

Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Demos and Protocol 34
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines