r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Other Projects  |  Topic: Blurry hud
Pages: [1]
Print
Author Topic: Blurry hud  (Read 14181 times)
starttimartti
Member

Posts: 32



« on: October 31, 2008, 09:09:31 am »

My hud icons get blurred in the latest r1gl and this wasn't the case with the previous version. I've attached an image to demonstrate. The icons are 8 bit pcx files and my video settings are as follows:
Code:
//video settings
set vid_ref "r1gl"
set gl_mode "6"
set gl_texturemode "GL_LINEAR_MIPMAP_LINEAR"
set gl_modulate "3"
set vid_gamma "0.5"
set gl_ext_palettedtexture "0"
set gl_ext_texture_filter_anisotropic "1"
set gl_ext_max_anisotropy "4"
set r_maxfps "900"
set vid_fullscreen "1"
set vid_flip_on_switch "1"
set cl_async "1"
set vid_forcedrefresh "0"


* hud.png (15.32 KB, 672x200 - viewed 878 times.)
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: October 31, 2008, 05:50:55 pm »

This is probably an artifact of resampling to powers of two. Ensure your hud icons are sized to powers of 2, or enable gl_ext_texture_non_power_of_two if your card supports it.
Logged
starttimartti
Member

Posts: 32



« Reply #2 on: October 31, 2008, 06:38:16 pm »

This is probably an artifact of resampling to powers of two.
Yeah I guessed as much, but I assumed it was a bug and not a feature, since it was not present in the previous version(s?) of r1gl.

Resizing the icons to 32x32 (from 24x24 that they were) does remove the problem.

Hopefully it will be fixed in the upcoming versions of r1gl, but if it not, I can totally live with the blurring. It's not like I can't read the icons.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #3 on: October 31, 2008, 06:54:34 pm »

While I wish I could set gl_ext_texture_non_power_of_two default to 1, history has shown yet again that many card / drivers don't properly implement OpenGL extensions.
Logged
puppy
Member

Posts: 11


« Reply #4 on: January 27, 2009, 08:56:03 am »

when i combine gl_picmip >0 (1,2,3  ...) and gl_ext_texture_non_power_of_two default  1, q2 looks like on screenshot. bug? videocard nvidia gf6600.
http://img220.imageshack.us/my.php?image=quake000fm6.png
Logged
st1gy
Member

Posts: 6


« Reply #5 on: July 06, 2010, 05:16:37 pm »

i have the same error with hud (blur) and picmip 1,2,3,4... (picture on the screen too bright) =(
p.s. crosshairs are blur too=( how i can fix it?
« Last Edit: July 06, 2010, 07:06:22 pm by st1gy » Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  Other Projects  |  Topic: Blurry hud
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines