r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Command to kick Q2ace Users and Ban Original FRKQ2
Pages: [1] 2  All
Print
Author Topic: Command to kick Q2ace Users and Ban Original FRKQ2  (Read 19930 times)
CaRn
Member

Posts: 52


« on: April 09, 2005, 04:48:41 pm »

I have the following commands set up to deny q2ace. 

sv_deny_q2ace "1"
sv_nc_visibilitycheck "2"
sv_nc_clientsonly "1"

Yet I still can log in using q2ace?  Is there something I am not doing correctly that anyone knows of?

Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: April 09, 2005, 05:00:23 pm »

sv_deny_q2ace only works if the q2ace chap.dll is present. Using cvarban on version string seems more effective, eg:

addcvarban version ~Q2ACE KICK Q2Ace is not allowed!

sv_deny_q2ace will likely be removed in the future.
Logged
CaRn
Member

Posts: 52


« Reply #2 on: April 09, 2005, 05:12:33 pm »

I have added this


addcvarban Version 1.21 KICK Q2Ace is not allowed!


I am still able to connect using q2ace 1.21

am i typing in the sytax incorrectly. 
Logged
CaRn
Member

Posts: 52


« Reply #3 on: April 09, 2005, 05:13:53 pm »

I am mainly wanting to ban all version of q2ace and old nocheat such as 2.32 and 2.34

Logged
CaRn
Member

Posts: 52


« Reply #4 on: April 09, 2005, 05:19:22 pm »

I got it to kick q2ace no thx.

Also do u know what syntax i would need to do to kick old nocheats such as 2.32 and 2.34
Logged
CaRn
Member

Posts: 52


« Reply #5 on: April 09, 2005, 05:21:18 pm »

I iddnt mean to say no thx

I meant to say THX!! Smiley
Logged
Bossman
Member

Posts: 486


« Reply #6 on: April 09, 2005, 07:18:09 pm »

sv_nc_kick [bitmask]
Kick users not matching NoCheat settings:
(add up the following values you want to use and set sv_nc_kick to this)
1 - require nocheat code
2 - require nocheat video check to pass
4 - require nocheat model check to pass
8 - require nocheat video check to pass
256 - kick any nocheat users    <----------------------this kicks all even 2.40 they are all old...... Now
« Last Edit: April 09, 2005, 07:20:59 pm by Bossman » Logged
CaRn
Member

Posts: 52


« Reply #7 on: April 09, 2005, 08:29:32 pm »

Yes, I have done that but a lot of people still use Nocheat 2.40b in Rocket Arena 2.  I am leaning towards requiring q2advance on the server possibly but OGL matches are nocheat required. 
Logged
Bossman
Member

Posts: 486


« Reply #8 on: April 10, 2005, 12:32:22 am »

Well you may as well just police the server. if you get it set up for 2.40 then no one else can get in.

Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #9 on: April 10, 2005, 07:52:47 am »

Not true. NoCheat is a joke - all versions have been hacked. Anyone forcing clients to use NoCheat and thinking their server is safe from cheaters is just kidding themselves. Same with any other forced client. It's just not worth it - let users play with whatever they want and find other ways of detecting cheaters. It's been proven several times already that forcing clients does not work.
Logged
Bossman
Member

Posts: 486


« Reply #10 on: April 10, 2005, 09:20:12 am »

That was my point when I said police server. He said his they require it in OGL
I agree it is all hacked and even the one with everyons hands in it is not good. No one is really working on a anticheat they are working on enhancing the nocheat so it looks good....To me that is not a anticheat it is something like this they are trying to do with it. So that is why just police and ban it is all that is left for now. This (r1q2) at least gives you a lot of tools and stuff to help with it.
Logged
J0k3r
Member

Posts: 15


« Reply #11 on: April 28, 2005, 05:05:44 pm »

There isn't no way to catch cheaters. Unless the cheater is just plain stupid. Which happens often. But until someone decides to either update Q2admin with some real detection other then detecting client side cvars or completely make a whole new server side cheat detection system the hackers will win. At least when you force a particular client to be used you cut down the amount of hacks that are available to the cheater. Then you only got a couple hacks to worry about instead of every hack that was ever made for Quake 2.
Logged
Bossman
Member

Posts: 486


« Reply #12 on: April 29, 2005, 07:37:08 am »

  That is a very good point too. JOk3r I gota say I agree with that statment.
Logged
CaRn|TWL|
Guest
« Reply #13 on: April 30, 2005, 06:08:23 pm »

I agree with what you said also.  Nocheat and Q2ace are the most hacked clients out there.  You have the whole era of St0rmix hacks/glhack and you have frkq2 for nocheat.  Evilpope has came out with Q2advance that I am enforcing on the Rocket Arena 2 ladder I am running.  It is by far the most advance cheat detection out there.  It is a living work in progress by someone who has played q2 for a long time.  You can check it out @ www.q2players.org/q2advance

I give props to R1CH on the new R1Q2 that fixes the gl_polyblend bug for me.  Q2ace and Nocheat should both be abandonded im my opinion they have came to the point where they are pretty much useless.  Banning cvars wont help if someone is tsearching and has a hacked nocheat client with a built in wallhack/bot.
Logged
Holyroller
Member

Posts: 9


« Reply #14 on: June 05, 2005, 12:22:47 am »

where do i put the command sv_deny_q2ace [0/1], ive put it in my q2admin cfg even tried to put it into my server.cfg q2ace can still get in.
Logged
Pages: [1] 2  All
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Command to kick Q2ace Users and Ban Original FRKQ2
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines