r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: Loading anticheat, this may take.... and quit without any error
Pages: 1 2 [All]
Print
Author Topic: Loading anticheat, this may take.... and quit without any error  (Read 25387 times)
eXecutor
Member

Posts: 13


« on: September 11, 2006, 07:50:08 am »

When my bro trying to connect to some anticheat server after

Loading anticheat, this may take a few moments...

after 1-2sec? he's q2 just quit with no errors, he got old good windows like when he turn on q2, wtf?
We got almost same computers, with same drivers, winxp etc.. what could that be?
at servers without anticheat is all ok, so i guess its smth with he's q2, pak or something else..

//edit with "my q2" copy from my hard drive its same.. ;/
« Last Edit: September 12, 2006, 03:04:39 am by eXecutor » Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: September 12, 2006, 01:58:28 pm »

Could you please post complete system specs - Windows version, SP, video/sound drivers, processor/RAM and such.
Logged
TgT
Member

Posts: 103


« Reply #2 on: September 12, 2006, 02:08:28 pm »

Thats was the problem i had, i was looking for a solution and next morning i reinstalled win32 Tongue I didnt find out what might be wrong for a whole evening until i fucekdup win32 and never got back in...  evil
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #3 on: September 12, 2006, 02:53:49 pm »

I've had a number of users with this problem and I'm not sure what causes it. I don't think any of them have fixed it without a WinXP reinstall either Sad. Hopefully I'll figure it out soon.
Logged
eXecutor
Member

Posts: 13


« Reply #4 on: September 13, 2006, 06:30:39 am »

k, so i got 3 computers with same system specs - drivers too
Processor: AMD Barton 2800+
Mainboard: Epox 8RDA3I  nforce2
Video Card: Gigabyte Ati Radeon 9600pro
Ram 512 kingston
Video drivers
date  2003-10-28
version 6.14.10.6396
the thing is that 1 of them - [mine komp10] is working OK, i got original winxp with sp2 at it
http://executor.internetdsl.pl/komp10.txt
thats from pc wizard 06, the 2 others cpu, are with winxp sp2 too, but with  crack Windows.Genuine.Advantage.Validation.v1.5.526.0.CRACKED-ETH0 to that win autentication shit..
http://executor.internetdsl.pl/komp9.txt
komp9 had win98, and i updated it with winxp cd, maybe thats it?! anticheat dont support win98, and maybe some dlls are still at drive and do some shit.. i will try newest video drivers in couple mins, and i will edit my post.. sorry for my bad english Wink

//edit so i download new omega drivers, and its same.. r1q2 just turn off when i try connect to some anticheat server.. the only difference is that at that another computer the number fps is in timerefresh -> 180-200, was smth like 800-1200 Wink

//edit i tested 2 more computers, with amd duron 1gb, 256ram, gf2 MX cracked windows geniue adv.. , same problem.. amd athlon 1800+ 256 ram, gf4MX same - original windows.. i got 15computers, some with org win, some with cracked WGA
3computers with win98 upgraded to xp, the rest installed normally.. but all with SP2 and all updates..
strange, only at my computer all its ok with anticheat.dll i got no time now, i have to go.. but tomorrow i will try some other client then r1q2 maybe, like aprq2? but i dont think it gonna help..
R1CH: You got suspicion what that would be?
« Last Edit: September 13, 2006, 07:43:35 am by eXecutor » Logged
Qiub
Guest
« Reply #5 on: September 16, 2006, 01:16:25 pm »

same here
 i have win xp sp2
celeron 1.7
 gf2mx 400 (drivers 6.3.10.3082)
sound card: avance AC'97 (driver: 5.10.0.3990 - 2002.09.06)
with epox 4pead
Logged
q2chile
Member

Posts: 51


« Reply #6 on: September 16, 2006, 04:14:15 pm »

winsockfix ?
Logged
eXecutor
Member

Posts: 13


« Reply #7 on: September 19, 2006, 05:56:26 am »

lol, helped i tested that on 2 computers and all is working just fine
http://rapidshare.de/files/29954901/WinsockxpFix.zip.html
or mine googled from some site
http://executor.internetdsl.pl/winsockxpfix.zip
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #8 on: September 19, 2006, 02:09:20 pm »

WinsockXPFix fixed it for you?
Logged
eXecutor
Member

Posts: 13


« Reply #9 on: September 20, 2006, 02:07:44 am »

yes.
some guys from Poland like Qiub got same problem, and fixed it with WinsockXPFix too.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #10 on: September 20, 2006, 02:10:11 am »

This issue seems to come up a lot... I wonder what the actual problem is.
Logged
eXecutor
Member

Posts: 13


« Reply #11 on: September 20, 2006, 03:47:32 am »

ye strange.. i got almost same system specs, all updates etc.. maybe some shit stuff from some games, like tibia's ipchanger, or multi tibia etc.. i dont see any difference at other my computers..
anyway winsockxpfix repair it, and thats cool.
Logged
QwazyWabbit
Member

Posts: 402


« Reply #12 on: September 20, 2006, 07:38:35 am »

Sounds like spyware got into their systems. Some spyware programs inject LSP services into the winsock stack and removal can be problematic. Many anti-virus products also install LSP or poke at the registry affecting winsock. Viruses and spyware attempting to bypass or disable the A-V product protections can mess it up.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #13 on: September 20, 2006, 12:10:03 pm »

That's what I thought too, but this seems unusually common even for spyware.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #14 on: September 24, 2006, 07:23:12 pm »

Any anti-virus or firewall software that is common to each machine?
Logged
eXecutor
Member

Posts: 13


« Reply #15 on: September 25, 2006, 06:35:56 am »

<-- all computers with nod32 trial cracked with some shit patch to xxxx days;], xp firewall [ sp2 ]
Logged
Maurox?
Member

Posts: 82


« Reply #16 on: September 25, 2006, 07:50:34 am »

<-- all computers with nod32 trial cracked with some shit patch to xxxx days;], xp firewall [ sp2 ]


disable imon service in NOD32 and the problem disapear :S
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #17 on: September 25, 2006, 03:34:40 pm »

So far all reports are from NOD32 users it seems... looks like IMON is to blame.
Logged
TgT
Member

Posts: 103


« Reply #18 on: September 25, 2006, 08:23:16 pm »

I didnt have any antivirus on my PC and got this problem, remember R1Ch ? Shocked
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #19 on: September 25, 2006, 09:09:52 pm »

Not really Smiley. There was another reason why it could have crashed on load though that I fixed before I think...
Logged
eXecutor
Member

Posts: 13


« Reply #20 on: September 26, 2006, 03:36:44 am »

yup, when connecting to anticheat server imon check?
http://www.r1ch.net/stuff/r1q2/update/update.ini [?]
and q2 just turn off..
when i turned off IMON the problem disapear Wink
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #21 on: September 26, 2006, 04:20:40 am »

Neither R1Q2 or anticheat make any HTTP requests unless using HTTP downloading, so I've no idea why IMON is even doing anything to R1Q2. The update.ini is only used by R1Q2 Updater. I tested using NOD32 trial on Windows 2000 and it worked fine with IMON on, so perhaps its just on XP or with an old/cracked NOD32 the problem occurs.
Logged
eXecutor
Member

Posts: 13


« Reply #22 on: September 26, 2006, 05:20:42 am »

that could be it, at that all computers when anticheat didn't worked i had
ESET.NOD32.v2.50.25 [Polish] trial with some NOD32.FiX.v1.9-nsane.exe crack
at that one computer [ mine, where r1q2 worked just fine ]
ESET.NOD32.v2.51.30.WinNT2K2K3XP.Cracked.REPACK-BRD
and imon from that nod32 didnt check update.ini or i'm blind Wink

So, when someone got that problem, just use winsockxpfix, or update Your nod32..
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #23 on: September 28, 2006, 04:53:59 pm »

Fixed! It turns out foreign language versions of NOD32 import a resource-only DLL to support the modified language strings which anticheat did not support until now.
Logged
Pages: 1 2 [All]
Print
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: Loading anticheat, this may take.... and quit without any error
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines