r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: new version(b283) seams slower
Pages: [1]
Print
Author Topic: new version(b283) seams slower  (Read 4364 times)
Anonymous
Guest
« on: January 01, 2005, 06:33:00 pm »

I cant speak for everyone, but this client seams slower to me, and a little laggy - maybe its just OCLD; but since i have a good ping and i dont lag AS much with regular q2, it would seam to be the client.
Logged
Voices{FLP}
Guest
« Reply #1 on: January 01, 2005, 11:20:54 pm »

yea  every few sec's it stuter steps
VERY anoying
I'm running a lithium server
Q2 admin 1.17
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #2 on: January 01, 2005, 11:27:20 pm »

Are you talking about the client or server? What build number, OS, CPU, RAM, etc? Do you see CPU/RAM usage spiking? Are you sure there are no network issues such as high latency or incoming/outgoing packetloss affecting it? I need details in order to even attempt to figure out what's going on.

For me, R1Q2 client b28xx+ is performing very nicely indeed and the server is handling 40 players on a P3-700 without even touching 50% CPU usage. I am not a big fan of q2admin so would likely point there as the problem before anything else. The server code should never cause any noticable slowdowns or stuttering.
Logged
Nick
Member

Posts: 211


« Reply #3 on: January 02, 2005, 06:21:36 pm »

I had two clients on my server tonight running the latest r1q2 client build for the first time.

Comments are 'it's bloody fast, but 'juttery'."

Speaking after the game in the pub, it appears there is some sort of packet loss/capping in no great detail.

Code:

server map: xdmt6
-------------------------------------
Savage[xxx]: protocol 35: "R1Q2 b2803 x86 Dec 21 2004 Win32 RELEASE"  <----------------
Zlartibartfast[xxx]: protocol 35: "R1Q2 b2803 x86 Dec 21 2004 Win32 RELEASE" <----------------
Lethe[217.204.244.146:59868]: protocol 34: "3.21 i386 Jan 2 2005 Linux"
TMBTY)MrBASTARD[xxx]: protocol 34: "3.21 x86 May 19 2002 Win32 RELEASE"
TIGGER[2xxx]: protocol 34: "3.21 x86 May 19 2002 Win32 RELEASE"
Stormwolf[xxx]: protocol 34: "3.21 NON-WIN32 Jun 29 2004 NON-WIN32"
Jansson[xxx]: protocol 34: "3.20 x86 Oct 16 1998 Win32 RELEASE"


No one else appeared to have problems.

Pings are all sub 100, average 60.

Nick
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #4 on: January 02, 2005, 07:30:15 pm »

This is probably due to the rendering / net frame rate separation. Try with cl_async 0 to revert to the normal Q2 behaviour of one frame per packet and see if it goes away. The "jitteryness" may be caused by small prediction errors that occur when the client is not sending packets every frame. If the "jitters" are happening mid-game though when not running into any walls or other entities, this may be due to a too high s_khz value - s_khz 44 will cause resampling for every sound which is a very slow process.
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: new version(b283) seams slower
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines