r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Other Projects  |  Topic: R1Q2/R1GL and dual monitors
Pages: [1]
Print
Author Topic: R1Q2/R1GL and dual monitors  (Read 4984 times)
Some Guy
Guest
« on: December 16, 2008, 10:57:27 pm »

Just a heads up:

I have a GeForce FX 5500 with dual outs. The D-Sub goes to a Viewsonic P255f (CRT), and the DVI goes to a Sharp Aquos D43U (720p LCD TV) via a DVI-HDMI cable. I usually run in clone mode with the CRT at 1024x768 @ 120Hz, and the TV at 1024x768 @ 60Hz. I usually have the TV off or on a show, so the clone mode is just in case I have a startup problem with my video drivers (which has happened in the past.)

Anyway when running R1Q2, if the clone mode is on, the displayed FPS never goes above 60. If I put on vid_forcedrefresh "120" and a vid_restart then it displays 120 FPS, but I'm afraid to turn on my TV. Normally I just turn off clone mode when running R1Q2, and it displays 120 FPS. It may just be the displayed FPS that is funky.

If you are still actually working on R1Q2/R1GL then you many want to look into this, if not, thanks for all your previous work.
 
R1Q2
 cl_async            "1"
 r_maxfps            "120"
 cl_drawfps          "1"
R1GL
 vid_forcedrefresh "0"

-Thanks
Logged
wision
Member

Posts: 237



« Reply #1 on: December 17, 2008, 05:46:07 am »

you don't need to run clone mode, use the settings with two separate desktops, then you can set whatever settings to each of those screens. anyway.. nothing should happend to the TV. it should just display smth like "out of range" i believe
Logged
Some Guy
Guest
« Reply #2 on: December 19, 2008, 12:30:40 am »

I just checked DualView for the first time. It seems to be exactly like Horizontal Span except full screen applications only fill up the 1st display. It does the same thing as clone mode.

I just noticed the vid_forcedrefresh 120 doesn't seem to work anymore in clone mode. Not sure what I was doing different this time. Something about changing the nView setting AFTER starting R1Q2. Anyway the FPS will not go above 60 while in Clone or DualView.

I can really see a difference between 60 and 120 FPS, it's one reason I haven't bothered to get an LCD until they have true 120 FPS.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #3 on: December 19, 2008, 03:41:15 am »

Refresh rate is meaningless on LCDs since they do not refresh like CRTs. Just use gl_swapinterval 0 or turn off vsync in your drivers.
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  Other Projects  |  Topic: R1Q2/R1GL and dual monitors
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines