r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Updater - Seg Fault
Pages: [1]
Print
Author Topic: Updater - Seg Fault  (Read 8434 times)
fanny
Member

Posts: 27


« on: January 18, 2005, 11:29:24 am »

R1CH, When I try to run the updater I get a sementation fault. I am running FC3 with 2.6 kernel and your latest r1q2ded server binary with q2admin 1.17 and stock 3.21 .so's. I have the executable in my quake2 directory.


Fanny
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: January 18, 2005, 12:36:13 pm »

Gotta love Linux and the absolutely terrible binary compatibility. Meanwhile I'm happily running .exe files from Windows 3.1 on a Server 2k3 box...

I'll see if I can clean up and post the updater source so you can build it yourself. In the mean time you can visit http://www.r1ch.net/stuff/r1q2/update/ to download the files manually.
Logged
fanny
Member

Posts: 27


« Reply #2 on: January 18, 2005, 08:14:46 pm »

knife in my heart!!!!, hehe. Ya I have a windoze 2K3 server box also and enjoy the ease at which it CRASHES (not really, fairly decent windoze product).

Thanks for your help
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #3 on: January 23, 2005, 12:54:01 pm »

For anyone interested the updater source code is now available. Yes, I'm aware it's terribly messy Smiley

It requires curl, zlib and OpenSSL. Build with the following:
Code:
gcc -O2 -o r1q2updater -lcurl -lz -lcrypto update.c

http://www.r1ch.net/stuff/r1q2/src/update.c
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Updater - Seg Fault
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines