r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: r1q2 cant read pak file right...
Pages: [1]
Print
Author Topic: r1q2 cant read pak file right...  (Read 3499 times)
xZm`
Member

Posts: 22


« on: June 21, 2007, 07:41:16 am »

i opened a new thread because of the name..

so, i have the problem, that my r1q2 seems to be not able to read my pak0.pak in a correct way:

ERROR: LoadTGA: (env/unit1_rt.tga): Pointer passed end of file - corrupt TGA file

i found the unit1_rt.tga, it is part of the standard pak0.pak file, which i copied from the cd. i do not think that my pak0.pak is corrupted, because i copied it now a plenty times and it dont work... Sad

any ideas what to do?
Logged
xZm`
Member

Posts: 22


« Reply #1 on: June 21, 2007, 07:56:07 am »

mhh, i tried the quake2 binary and the gamei386.so from cvs and from stable source, but nothing changes... so maybe it has something to do with the modded r1gl (for compiling i used q_shared.c + q_shared.h from the stable source, because otherways make crashes...)
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #2 on: June 21, 2007, 04:19:38 pm »

Yes, R1GL has this check to avoid reading past the end of a file. I'm not sure why you're getting this error, I'll look into it on more detail tonight.
Logged
xZm`
Member

Posts: 22


« Reply #3 on: June 22, 2007, 02:07:04 am »

thank you, ur great Smiley
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #4 on: June 22, 2007, 02:35:49 am »

The gl_image.c in CVS fixes this.
Logged
xZm`
Member

Posts: 22


« Reply #5 on: June 22, 2007, 10:14:07 am »

thx, u really made my day! Smiley

PS: really pity that anticheat-module is only for windows users :/
« Last Edit: June 22, 2007, 10:49:51 am by xZm` » Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: r1q2 cant read pak file right...
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines