r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Joystick support?
Pages: 1 [2]  All
Print
Author Topic: Joystick support?  (Read 10810 times)
R1CH
Administrator
Member

Posts: 2625



« Reply #15 on: February 15, 2005, 07:55:48 am »

Do you see "joystick initialized" in the console? Also check the in_joystick cvar.
Logged
trinity
Member

Posts: 4


« Reply #16 on: February 15, 2005, 08:37:24 am »

This is my whole cfg so maybe this way is easier ive nothing to hide Wink

bind TAB "inven"
bind ENTER "invuse"
bind ESCAPE "togglemenu"
bind SPACE "+moveup"
bind ' "invdrop"
bind + "sizeup"
bind , "+moveleft"
bind - "sizedown"
bind . "+moveright"
bind / "weapnext"
bind 0 "use BFG10K"
bind 1 "use Blaster"
bind 2 "use Shotgun"
bind 3 "use Super Shotgun"
bind 4 "use Machinegun"
bind 5 "use Chaingun"
bind 6 "use Grenade Launcher"
bind 7 "use Rocket Launcher"
bind 8 "use HyperBlaster"
bind 9 "use Railgun"
bind = "sizeup"
bind [ "say_team - [POWER SHIELD] 60 -;play timers/ps60.wav"
bind \ "use power shield"
bind ] "say_team - Dropping [PS] -;drop Power Shield "
bind ` "toggleconsole"
bind a "say_team - BASE CLEAR -"
bind b "say_team - BASE NOT SAVE -"
bind c "say_team - Dropping [CELLS] -;drop cells "
bind d "say_team - Trini is DEAD!! -"
bind e "say_team - ENEMY [QUAD] -"
bind f "The Matrix has YOU"
bind g "play timers/quad60.wav; say_team {{{ Enemy Quad 60 {{{"
bind h "say_team - IM THE [FC] NEED HELP -"
bind i "say_team - INCOMING QUAD -"
bind j "wave 1"
bind k "inven"
bind l "invnext"
bind m "say_team - MEGA AVAILABLE -"
bind n "say_team - NO / NEGATIEVE -"
bind p "drop power shield"
bind q "play timers/quad60.wav; say_team {{{ Quad 60 {{{"
bind r "say_team - Dropping [ROX] -;drop rockets"
bind s "say_team - Dropping [SLUGS] -;drop slugs"
bind t "messagemode"
bind u "wave 4"
bind w "play timers/quad30.wav; say_team {{{ Quad 30 {{{"
bind x "dtech"
bind y "say_team - AFFIRMATIVE / YES -"
bind z "+klook"
bind ~ "toggleconsole"
bind BACKSPACE "say_team I Have %t"
bind UPARROW "+forward"
bind DOWNARROW "+back"
bind LEFTARROW "+left"
bind RIGHTARROW "+right"
bind ALT "messagemode2"
bind CTRL "+attack"
bind SHIFT "+speed"
bind F1 "cmd help"
bind F2 "menu_savegame"
bind F3 "menu_loadgame"
bind F4 "menu_keys"
bind F5 "menu_startserver"
bind F6 "echo Quick Saving...; wait; save quick"
bind F9 "echo Quick Loading...; wait; load quick"
bind F10 "mset timelimit 20; mset dmflags 411156; mset weaponflags 1025; pset timelimit 20; pset dmflags 411156; pset weaponflags 1025"
bind F11 "mset timelimit 10; mset dmflags 526342; mset weaponflags 1; pset timelimit 10; pset dmflags 526342; pset weaponflags 1"
bind F12 "screenshot"
bind INS "say_team - enemy esc [FC] RAILROOM "
bind DEL "say_team - enemy esc [FC] MAIN "
bind PGDN "say_team -enemy esc [FC] PIPE / WATER "
bind PGUP "+grap4"
bind END "say_team - enemy esc [FC] CHAIN "
bind KP_LEFTARROW "+sniper"
bind KP_END "+moveleft"
bind KP_DOWNARROW "+back"
bind KP_PGDN "+moveright"
bind KP_SLASH "+speed"
bind MOUSE1 "+attack"
bind MOUSE2 "+strafe"
bind MOUSE3 "+forward"
bind JOY1 "+attack"
bind JOY2 "say_team _ENMY_FC_ESCAPING_[PIPE]"
bind JOY3 "centerview"
bind JOY4 "say_team _ENMY_FC_ESCAPING_[RAIL]"
bind AUX5 "say_team _ENMY_FC_ESCAPING_[MAIN]"
bind AUX6 "+gtik"
bind AUX7 "+moveup"
bind AUX8 "+movedown"
bind AUX10 "+attack"
bind AUX29 "+lookdown"
bind AUX30 "weapnext"
bind AUX31 "+lookup"
bind AUX32 "play ps60.wav; say_team {{{ POWERSHIELD 60 {{{"
bind PAUSE "pause"
set cl_gun "1"
set gl_3dlabs_broken "1"
set gl_ext_compiled_vertex_array "1"
set gl_ext_pointparameters "1"
set gl_ext_multitexture "1"
set gl_ext_palettedtexture "1"
set gl_vertex_arrays "0"
set gl_texturesolidmode "default"
set gl_texturealphamode "default"
set gl_texturemode "GL_LINEAR_MIPMAP_NEAREST"
set gl_driver "opengl32"
set gl_finish "0"
set gl_particle_att_c "0.01"
set gl_particle_att_b "0.0"
set gl_particle_att_a "0.01"
set gl_particle_size "40"
set gl_shadows "0"
set gl_modulate "3"
set gl_particle_max_size "5"
set gl_particle_min_size "1"
set gl_mode "6"
set gl_ext_swapinterval "1"
set gl_swapinterval "0"
set in_joystick "1"
set cl_vwep "1"
set gender_auto "1"
set gender "none"
set fov "90"
set rate "8000"
set freelook "0"
set adr8 ""
set adr7 ""
set adr6 ""
set adr5 ""
set adr4 ""
set adr3 ""
set adr2 ""
set adr1 ""
set adr0 ""
set s_primary "0"
set s_mixahead "0.2"
set s_loadas8bit "0"
set s_khz "44"
set s_volume "0.7"
set sw_stipplealpha "0"
set vid_gamma "1.000000"
set vid_ypos "22"
set vid_xpos "3"
set vid_ref "gl"
set allow_download_maps "1"
set allow_download_sounds "1"
set allow_download_models "1"
set allow_download_players "0"
set allow_download "1"
set hostname "noname"
set skin "bh/tri_r"
set name "bh.Trinity"
set lookstrafe "0"
set lookspring "1"
set m_pitch "0.022"
set hand "2"
set cl_run "1"
set crosshair "1"
set sensitivity "3"
set win_noalttab "0"
set vid_fullscreen "1"
set viewsize "100"
Logged
XyMoX
Member

Posts: 24


« Reply #17 on: February 17, 2005, 04:28:18 am »

Uh-oh...

Houston we have a problem....
Now that I have my server the way I want it to be,  I have been concentrating a little more on the client.

The joystick does work with r1q2 client.
However, not completely.

I use the the joystick's Y-axis (forward and back) and X-axis (strafe left/right) for my movement.
Prior to using the r1q2 client, I could actually slow down (walk) by using slight movements on the joystick.
Those "threshold zones" are now missing.

In other words, no matter how slight or drastic I move the joystick, I will "run" at full speed, I have no more ability to "walk". Not only does it make it difficult to be stealthy, but looking over edges of high buildings is very difficult without falling. undecided

I tried changing the values of these commands...
joy_pitchsensitivity
joy_pitchthreshold
joy_sidesensitivity
joy_sidethreshold

and nothing seems to make it work.
I think that these commands are perhaps not activated with r1q2?

Thx
Logged
XyMoX
Member

Posts: 24


« Reply #18 on: February 20, 2005, 05:46:27 am »

So R1ch,

Are you going to check into this or we going to expect to play like Quake3?  tongue
Logged
XyMoX
Member

Posts: 24


« Reply #19 on: February 26, 2005, 03:16:14 am »

*bump*  rolleyes
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #20 on: February 26, 2005, 05:04:40 am »

What are you using for cl_async?
Logged
XyMoX
Member

Posts: 24


« Reply #21 on: February 28, 2005, 04:35:24 pm »

Bingo!

I was using cl_async 1.
Tried using cl_async 0 and it worked fine.

Any way of making it work with async on?
Logged
Bossman
Member

Posts: 486


« Reply #22 on: June 05, 2005, 04:06:48 pm »

  sorry wrong one
« Last Edit: June 05, 2005, 04:09:52 pm by Bossman » Logged
Pages: 1 [2]  All
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Joystick support?
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines