r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: R1Q2 and singleplayer
Pages: [1]
Print
Author Topic: R1Q2 and singleplayer  (Read 10669 times)
_on_Fire
Guest
« on: October 27, 2004, 06:17:28 am »

I can't seem to use r1q2 (b1387) with normal singleplayer quake.

It always says:  ERROR: Couldn't load maps/ntro.cinn.bsp
when I try to start a singleplayer game. When I have the cinematics
installed and even when I don't have them installed.

Am I doing something wrong here? Is there an easy way around this?

Or is this a small bug, that will be fixed someday?
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: October 27, 2004, 06:32:05 am »

R1Q2 doesn't have support for cinematics (idlogo, intro, endgame) as it is really quite a large chunk of code for something that is hardly used by 99% of players. At the moment the code is a little messy and will just dump to the console if you try loading a .cin, I'll try and make it just skip over it in future.

In the mean time, just start a new game from the console rather than the menu by typing:
skill 2 (or whatever)
deathmatch 0
maxclients 1
map base1
Logged
_on_Fire
Guest
« Reply #2 on: October 27, 2004, 06:57:50 am »

Thanks for the fast reply. Smiley

Personally I couldn't care less if cinematics aren't supported, but it would
surely be nice if in the future it would skip them.

Starting from the console will do for now.

But for other singleplayer mods, I'd have to dive into the pak file to find
out what  map is the start map. Not much work, but still...

I'll be eagerly awaiting that cinematic skipping feature  Cheesy
Logged
_on_Fire
Guest
« Reply #3 on: November 25, 2004, 04:25:35 am »

When I start a singleplayer game in b1788 and b1915 it stays in the console, like before, but now it says "Connecting to localhost..." and keeps repeating that ad infinitum. It doesn't start the singleplayer game.

Is this a bug or have i set up something the wrong way?

Also r1q2 crashes now sometimes when i use the r1gl renderer, but that's probably due to the nvidia 67.02 beta drivers I'm using. So it's not that important.  Cheesy
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #4 on: November 25, 2004, 05:09:30 am »

Hmm so it does. So much for my "slow down on the releases" Sad. Wonder what I changed to cause that...
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #5 on: November 25, 2004, 05:18:15 am »

b1916 (Win32 client only) on updater should fix it.
Logged
_on_Fire
Guest
« Reply #6 on: November 25, 2004, 12:55:18 pm »

Running b1917 now and singleplayer works.

Thanks R1CH.  Cheesy
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: R1Q2 and singleplayer
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines