r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Windows Vista and R1Q2
Pages: [1]
Print
Author Topic: Windows Vista and R1Q2  (Read 3561 times)
Manic Miner
Member

Posts: 2


« on: January 03, 2007, 08:59:01 am »

Does anyone have R1Q2 working under windows vista?

I have pretty much a vanilla installation of a genuine copy of Windows Vista (Ultimate), quake2 from the quake2 CD which has been patched using the full 3.20 ctf updater exe.  Quake2 works perfectly (in fact more than perfectly well) in OpenGL.

I've downloaded R1Q2 client from the web site, extracted it into the quake2 folder (also downloaded and run the auto updater).  When I run R1Q2 the screen goes black as though Quake2 is about to run, but then errors with a message box asking me if I want to add a debug break point (warning for developers only).  As I've no dev tools on that machine I've done nothing much at that point.

I've tried setting various compatibility modes with no luck.  My graphics card is a nVidia GeForce 7800GTX 256Mb.

People having sucess with R1Q2 and Windows Vista or anyone got any ideas?
« Last Edit: January 03, 2007, 09:03:05 am by Manic Miner » Logged
Manic Miner
Member

Posts: 2


« Reply #1 on: January 03, 2007, 01:20:35 pm »

hmmm ignore that request ... i noticed there were a newer set of nVidia drivers out than the one's I'd installed a couple of weeks ago and they appear to have fixed the problem.

although if anyone knows how to disable vsync under vista it would be helpful Smiley Wink
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #2 on: January 03, 2007, 03:52:32 pm »

If you're using R1GL, gl_swapinterval 0 should have the same effect as disabling vsync.
Logged
beans
Member

Posts: 14


« Reply #3 on: January 05, 2007, 04:28:03 pm »

I am running both a server and a client on a Windows Vista Business edition without issue. in fact I have seen performance  increases and no crashes...

and gl_swapinterval 0 correctly work the same as disabling vsync.

great job r1ch
Logged
fimpen
Guest
« Reply #4 on: July 15, 2007, 04:15:51 am »

i have vista home premium and r1q2 does not work on my machine at all, old quake runs great after i update it with r1q2 the graphics dissapear or flashes.
Logged
fimpen
Guest
« Reply #5 on: July 15, 2007, 04:19:04 am »

i have vista home premium and r1q2 does not work on my machine at all, old quake runs great after i update it with r1q2 the graphics dissapear or flashes.
I mean quake2 of course, i have a fujitsu siemens with x1100 ati radeon card
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: Windows Vista and R1Q2
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines