r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: R1GL system freeze using HD6950
Pages: [1]
Print
Author Topic: R1GL system freeze using HD6950  (Read 5211 times)
neoxotb
Guest
« on: March 13, 2011, 12:24:32 pm »

Built a new Windows 7 Pro x64 PC. Decided to go the AMD over nVidia this time around and selected a HD6950. Copied the Quake 2 directory from my old computer. Started up and joined ACME CTF, played for a few minutes and then system totally bombed out. Thought Catalyst Control Panel might have been causing the issue, so I turned vertical sync to application controlled and tried gl_swapinterval 0. Crashed again after a few minutes. Also tried to run as administrator, no luck. Here's my config I'm trying to run with:

Code:
gl_dynamic "0"
gl_polyblend "0"
cl_particles "0"
s_initsound "2"
cl_defermodels "0"
m_directinput "1"
cl_async "1"
cl_maxfps "66"
r_maxfps "120"
gl_dynamic "1"
gl_polyblend "0"
scr_crosshair_x "0"
scr_crosshair_y "0"
cl_particles "0"
cl_defermodels "0"
cl_railtrail "2"
m_directinput "1"
m_fixaccel "0"
cl_smoothsteps "1"
cl_instantpacket "1"
set s_initsound "1"
set s_khz "44"
set gl_ext_texture_filter_anisotropic "1"
set gl_ext_max_anisotropy "8"
set gl_ext_multisample "1"
set gl_ext_samples "4"
set gl_ext_texture_non_power_of_two "1"
set gl_noscrap "1"
set vid_flip_on_switch "1"
set vid_forcewidth "1920"
set vid_forceheight "1200"
gl_hudscale "2"
vid_restart
snd_restart

This is what shows in the Windows event viewer after the lockup, no help really:

Source: Kernel-Power Event ID: 41
The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

And every time, a few seconds before it locks up I'm seeing this in the event viewer:

File System Filter 'FileInfo' (6.1, ?2009?-?07?-?13T18:34:25.000000000Z) has successfully loaded and registered with Filter Manager.
- System

Don't know if the two are connected are not, could be a possibility. Not having this issue in any other game. I switched to default OpenGL in Quake 2 and it didn't crash after about 20 minutes running around on a few maps. With R1GL enabled anywhere from 1-5 min and I'll be frozen.

Didn't know if this is AMD specific, since I was using nVidia before. Default openGL is kinda crappy after using R1GL for so long.

Logged
mhanor
Member

Posts: 120


« Reply #1 on: March 14, 2011, 01:15:46 pm »

It's a hardware issue or a video driver problem, it can't be r1gl's fault, even if it's triggering the crash.
You can try and update your Catalyst drivers, 11.2 are the latest.
Also, try setting gl_ext_texture_non_power_of_two to 0
« Last Edit: March 14, 2011, 01:20:32 pm by mhanor » Logged
neoxotb
Guest
« Reply #2 on: March 14, 2011, 01:54:40 pm »

Downloaded latest Catalyst drivers Friday when I loaded PC, pretty sure those are updated unless they've released some over the weekend, will double check when I get home. I might try just a standard reinstall without any of my old config files and toggle r1gl to see if it crashes. I will try your suggestion of gl_ext_texture_non_power_of_two "0" first though. Thanks.
Logged
neoxotb
Guest
« Reply #3 on: March 14, 2011, 05:15:20 pm »

Woot, seems to work fine now. Thanks for the tip mhanor.

Guess I should learn to read >>
   Enable uploading of textures that are not a power of two. This is supported by most new cards, however it is disabled by default since some ATi drivers behave poorly with it enabled. Enabling this may speed up loading times.
Logged
neoxotb
Guest
« Reply #4 on: March 14, 2011, 10:34:02 pm »

Or not, seemed like it was going to work but ended up locking yet again. Was a good 25 minutes before it crashed this time though. Will try the clean R1Q2/R1GL to see if anything changes undecided
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: R1GL system freeze using HD6950
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines