r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: r1q2 and high cpu usage...
Pages: [1]
Author Topic: r1q2 and high cpu usage...  (Read 4582 times)

Posts: 5

« on: August 11, 2008, 06:25:48 pm »

Hi r1ch.. I have an issue similar to the one here : http://www.r1ch.net/forum/index.php?topic=1043.0.
Instead of resurrecting such an old thread I figured I'd start a new topic.

Not sure when this started, could have been forever but I didn't think to investigate until I noticed my cpu was 30c idle/r1q2 minimized.. and 55c+ after playing for a while.

Basically :

r1q2 minimized = cpu 0-1%
r1q2 opened but not connected to a server = cpu 50%+
r1q2 opened and connected to any server = cpu 95%+

I'm including screen shots of the above but here's a little more info :

r1q2 is set to normal priority in task manager.
I do use r1gl.
This issue exists with and without anticheat.
All drivers are current. (video, sound, etc..)
I've tried with closing almost all programs running in background.

A few specs:

running r1q2 @ 800x600 and 1024x768 both at 85Hz.
Amd 4400+ @ 2.2GHz
2 gig memory
(nothing overclocked)

cl_async "1" (tried 0 and 1)
set cl_maxfps "120" (tried 33, 66, and 120.. same effect)
set r_maxfps "1000" (tried everything from 120, 333, 1000.. same effect)

Hopefully that's enough information for you, let me know if you need anything else.



Posts: 2625

« Reply #1 on: August 11, 2008, 07:01:17 pm »

Disabling vsync causes R1Q2 to run as fast as possible, 100% CPU use is normal under such circumstances. Ensure you aren't forcing vsync off on your drivers and gl_swapinterval is set to 1.

Posts: 5

« Reply #2 on: August 11, 2008, 08:08:26 pm »

Okay gotcha.
I thought that lowering the r_maxfps limited the fps and thus not allowing R1Q2 to run as fast as possible, sorry about that.
Pages: [1]
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  Topic: r1q2 and high cpu usage...
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines