r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Bitchbot  |  Topic: only 1st time conenctiing works, after that ...
Pages: [1]
Print
Author Topic: only 1st time conenctiing works, after that ...  (Read 9200 times)
ole
Guest
« on: August 23, 2006, 10:04:35 am »

similar to thoose guys (/forum/index.php?topic=37.0) i have the problem of "tinkerbell" connecting to the server, (i can /whois it and /msg it..) but not joining the designated channel.
i can solve the problem by deleteing the log files and the /data/ directory, every time before booting teh bot.

stats:
 - no addons used (i tried to use the spawn.bat but error kept comming)
 - winxp , using PXPerl not ActivePerl (but that shouldnt be the problem, is it ?)
 
 - getting 2 error msgs during starting the bot, even when i start up fresh. log reads:

   No Such Signal. SIGPWR at C:\Programme\PXPerl\bin\bitch.pl Line 172.
   Executing config file...   [ OK ] .....
   Trying Time::HIRes...     [ OK ] ...
   Trying to set Alarm...     [ OK ] ...
   Loading Factoids...        [ OK ] ...
   Connecting to server... [ OK ] ...
   Use of Uninitilased Value in String eq at C:\.....\bitch.pl Line 947, <SOCK> Line 22.



   
Logged
ole
Guest
« Reply #1 on: August 30, 2006, 04:40:34 am »

it seems the bot has problems with key/passowrd protected channels. it works fine now in another channel.
a non clean way to avoid the bug, is setting $channel to "#channelname chankey" and leave the $key blank. NOTE: this may cause other bugs. i havent noticed any, but i didint test alot of stuff.

beside that i have noticed this two bugs:
  the bot wont start polls ("Must have at least two choices!") . i was told its becasue of the "|". (general bug)
  the bot wont "cyborg WORD"  or techfy. replys:  "connect: Unknown error" (not sure if its my setting or a general problem tho)

th for support and solutions Smiley

ole
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  Bitchbot  |  Topic: only 1st time conenctiing works, after that ...
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines