r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Other Projects  |  Topic: ForceBindIP - Parameter support?
Pages: [1]
Author Topic: ForceBindIP - Parameter support?  (Read 27323 times)

Posts: 1

« on: April 06, 2007, 01:37:33 pm »

Hi there,

First of all i respect your work, a job well done!
I'm currently trying to use ForceBindIP with an application that requires a parameter, however when attempting to run the application using the parameter it won't recieve it.

I attempt to run it as such:

forcebindip -i "D:\Program Files\MyApp\MyExe.exe" 16
forcebindip - i D:\MyApp\MyExe.exe 16

16 being the parameter required.

Both won't work for me, the parameter will never be passed to MyExe.
Is it currently not supported?

If not, would it be too much to ask for an update ?

Kind regards and keep up the good work,
J. van Vierzen
« Last Edit: April 07, 2007, 05:00:39 am by J4zen » Logged

Posts: 11

« Reply #1 on: May 07, 2007, 10:33:28 pm »

Im going to go out on a limb here and say microsoft changed something cause i cant get it to work at all with any program, even without passing parameters to an application.

xp pro sp2 with latest updates to date, ie7
« Reply #2 on: May 21, 2007, 01:53:57 pm »

I find that the parameter after the executable is ignored, so try: forcebindip - i D:\MyApp\MyExe.exe blahblah 16
« Reply #3 on: May 23, 2007, 01:08:00 pm »

Finally, the program I've been looking for, and it isn't working for me.  Since this appears to be the only topic on the ForceBindIP program, I'm posting here too.  I'm having the same problem as Slimey.

I have two internet conenctions. One is on a LAN which uses a satellite connection through hughesnet, which limits the bandwidth.  The other is a dialup conenction.  I'm trying to get Firefox to use my highspeed connection through my LAN connection and Azureus use the dialup connection so it doesn't hog the highspeed bandwidth and throw me into FAP (another story).  Luckily, Azureus has built-in IP binding.  But if I'm connected on dialup, every program uses the dialup and nothing uses the LAN.  I'm using bandwidth monitor pro to tell me which connection is being used.

Then I find this program.  At first, using ForceBindIP with Firefox and using my LAN cards static private IP address, Firefox can't connect to anything and no pages will load.  If I put in the adapters registry key, then Firefox still just used the dialup connection.  Now, it doesn't matter if I use the IP or the registry key, with or without -i, Firefox can't connect.

I'm also running Windows XP Pro SP2 with latest updates and Firefox with several extensions. 

BTW, I also tried it on Yahoo Messenger.  YMessenger locks up without -i and won't connect with either IP or reg key.  Can anyone verify that this program works for them?  Especially on a XP Pro SP2 system?

Another thought,  all of these programs are located in Program Files, which has a space and requires the use of quotes.  Could the use of quotes be causing a problem?

Posts: 2625

« Reply #4 on: May 23, 2007, 05:31:26 pm »

Try using the DebugView utility from www.sysinternals.com - when ForceBindIP does stuff, it should output debug messages which are visible to DebugView which might help isolate what's going wrong.
« Reply #5 on: July 31, 2007, 06:19:19 am »


This is an awesome idea for a utility. I also figured this is the best place to make the post since there are other people with similar problems. I'm running multiple dial-up connections and an internet connection over fixed LAN IP, and would like to bind certain programs to certain interfaces. (exactly what this program does). Problem is, its not working Sad The application i opened using forcebindip is still using the latest connection that was made.

I've tried the debugview utility and notice nothing out of the ordinary. Especially when i run firefox.exe there isnt even a single event.

Any ideas? It would be awesome to get it going. Many thanks.
« Reply #6 on: October 15, 2007, 01:37:04 pm »


Assuming your running Win XP, go to Control Panel > Network Connections. From the Advanced Menu > Advanced Settings > Adapters and Binding Tab. Here you can choose the order in which Windows will use the available connections. For your needs, set the first one to be your highspeed Ethernet (so thats the default one) and second to your dialup. Configure Azureus to use the dialup. From now, all programs ither than Azureus will be connected via the LAN. Only Azureus will use the dialup (same applies to the uTorrent client also)

I think your issue is the same as zealots' . After you start a program via forcebindip, if you make a new connection (dialup or otherwise) windows sometimes puts it in the list of available connections at the highest priority; I think this screws up forcebindip's injection.

Other notes: forcebindip will inject itself to the connection calls made ONLY BY THE INSTANCE IT SPAWNED not others. So for example, if you have a media player streaming from the internet (VLC for example) that was spawned via forcebindip, and then double click on a .pls or .m3u file to an internet stream from explorer, it spwans ANOTHER INSTANCE of the media player EVEN IF YOU HAVE CONFIGURED YOUR MEDIA PLAYER TO BE A SINGLE INSTANCE. The instance spawned by forcebindip is gone.
« Reply #7 on: February 15, 2010, 01:25:10 pm »

create a batch file (i.e. test.bat):
yourfile.exe -allthearguments

and then run forcebindip "C:\test.bat"
« Reply #8 on: April 22, 2010, 04:09:26 am »


i have the same problem as J4zen that ForcebindIP doesn't pass parameters to the called program.

I'm trying to assign Firefox Portable to a spezific network interface card, but it isn't working.
The portable edition of Firefox is using a loader, to call the Firefox.exe file.

So there are three possibilities to keep Firefox portable:

1) Using the loader in the ForceBindIP commandline, but in this case the loader is connected to the Network card and not Firefox.
-Not working-  sad

2) Passig the corresponding parameters (ie. Firefox.exe -profiles My_profile) manually to firefox.exe, but this isn't working, because ForceBindIP 1.2a doesn't pas the first parameter (Thanks Norman).
I find that the parameter after the executable is ignored, so try: forcebindip - i D:\MyApp\MyExe.exe blahblah 16
-Not Working-   smiley

3) Solution:
--> ForceBindIP {A0FE4B6C-6BC2-4279-A087-2262C790C254}  "c:\My Documents\Software\FirefoxPortable\app\firefox\Firefox.exe" Notpassed -profile data\profile <--
-Working-   smiley

Notpassed ist a dummy, -profile data\profile is the path to the profile directory, ForceBindIP is called from the directory where the original FirefoxPortable.exe file resists.



Pages: [1]
r1ch.net  |  r1ch.net stuff  |  Other Projects  |  Topic: ForceBindIP - Parameter support?
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines