r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Bitchbot  |  Topic: wee issue with ignore and fake hostmasks
Pages: [1]
Print
Author Topic: wee issue with ignore and fake hostmasks  (Read 5485 times)
raena, a bitchbot n00b
Guest
« on: August 11, 2004, 02:43:15 pm »

Hi,

I'm really loving bitchbot! Cheesy It's marvelous.

One problem I am having, though, is with the ignore function.  On the Gamesurge network, you can have a custom hostmask along the lines of yournick.users.gamesurge - but the problem there is that if I tell bitchbot to ignore someone who's using it, it ignores *!*@*.user.gamesurge.  What I'd like it to do in these cases is to add *!*@thename.user.gamesurge, but behave normally for people who don't have the custom hostmask.

I blow goats where perl is concerned and i'm not sure where or how to hack it to do this.  Can anyone help?

TIA, and thanks for bitchbot too!

- r
Logged
raena the n00b
Guest
« Reply #1 on: August 11, 2004, 03:18:00 pm »

I also note that it seems to behave the same way for voting and polling - if one person using the *.user.gamesurge mask casts a vote, everyone else with a gamesurge mask is told they already voted.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #2 on: August 17, 2004, 11:34:14 pm »

You should be able to add custom ignore masks eg *!*@users.exact.host using the ignore command too.
Logged
raena
Guest
« Reply #3 on: August 21, 2004, 04:27:36 am »

That doesn't help with the voting, though.
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  Bitchbot  |  Topic: wee issue with ignore and fake hostmasks
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines