r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: Anticheat & xfire not compatible?
Pages: [1] 2  All
Print
Author Topic: Anticheat & xfire not compatible?  (Read 25108 times)
HaOhMaRu
Member

Posts: 7


« on: October 12, 2006, 04:40:09 pm »

why anticheat kick me for is using xfire huh cry, i know xfire use opengl for talk but not have wallhack :S clear this command plis!! Sad
Logged
HaOhMaRu
Member

Posts: 7


« Reply #1 on: October 12, 2006, 04:40:34 pm »

Logged
Gen
Member

Posts: 56



« Reply #2 on: October 12, 2006, 06:10:33 pm »

bueno ahi esta la respuesta por que de alguna manera modifica el opengl

Well the answer is there, because xfire modify in someway opengl
Logged
HaOhMaRu
Member

Posts: 7


« Reply #3 on: October 12, 2006, 06:13:46 pm »

pero con msn pasa lo mismo po si te vas a windows y se conecta alguien y entras denuevo al quake 2 se abre la vewntana pero no se ve wall :S
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #4 on: October 12, 2006, 07:47:54 pm »

I've been slowly trying to track down the causes of modified opengl memory, since soon anticheat will be requiring a valid opengl for extra security. It seems Xfire modifies opengl memory which unfortunately is the same way a hack could modify opengl, so no modifications to opengl are allowed now. If Xfire has an option to disable opengl hooks or disable DLL injection you should turn that on to avoid problems.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #5 on: October 12, 2006, 11:40:18 pm »

I will try and make anticheat compatible with xfire, but xfire seems to update quite often as I already have seen four different versions. Right now I want to find out what is causing other instances of modified opengl memory so I have more info on how to proceed.

Update: I sent off an email to the Xfire guys asking for some info on what they modify in OpenGL so I can try to work alongside it. I hope they can help me out as I really don't want to go comparing the memory manually and relying on disassembly as it may differ from system to system based on Xfire options or something (I've never used Xfire).
« Last Edit: October 13, 2006, 03:25:16 am by R1CH » Logged
HaOhMaRu
Member

Posts: 7


« Reply #6 on: October 13, 2006, 10:51:57 am »

:O ty Smiley try plis
Logged
Cunnilson
Member

Posts: 21


« Reply #7 on: October 13, 2006, 11:05:26 am »

soon anticheat will be requiring a valid opengl for extra security.

great
Logged
AirRide
Guest
« Reply #8 on: October 13, 2006, 02:46:58 pm »

Yeha!
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #9 on: October 13, 2006, 05:04:03 pm »

The Xfire team got back to me with the information I needed, so I'll work on making it compatible with Xfire tonight Smiley.
Logged
X7
Member

Posts: 43



« Reply #10 on: October 14, 2006, 07:09:23 pm »

So has this been fix yet, I like my Xfire.   grin



Code:
Precache completed in 3898 msec.
anticheat X7[Q2C] was kicked for anticheat violation (opengl-hooker)
Please do not use Xfire when using anticheat. Any programs that modify OpenGL are not allowed.
Disconnected by server!
Logged
HaOhMaRu
Member

Posts: 7


« Reply #11 on: October 14, 2006, 08:39:42 pm »

mmm the program TSO (Team Speak OVerlay) i have problem =/ i can see who speak in TS but kick me the server Sad 
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #12 on: October 15, 2006, 07:38:07 am »

Unfortunately these programs all modify OpenGL memory which makes them hard to tell from a wallhack. I'm trying to figure out how they work and if I can add exceptions for them.
Logged
HaOhMaRu
Member

Posts: 7


« Reply #13 on: October 15, 2006, 03:50:42 pm »

but xfire what happened?
Logged
Gen
Member

Posts: 56



« Reply #14 on: October 15, 2006, 04:19:43 pm »

just wait  a second more..
Logged
Pages: [1] 2  All
Print
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: Anticheat & xfire not compatible?
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines