r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: Quake II Fatal Error
Pages: [1]
Print
Author Topic: Quake II Fatal Error  (Read 7613 times)
Wake
Guest
« on: November 07, 2006, 11:42:59 am »

I'm finally getting tired enough of this to do something about it. Sometimes when I switch from ACME's public server to the match server my r1q2 closes out and I get this error:

"Couldn't GetProcAddress Initialize on anticheat.dll!"

What does that mean? I downloaded a new anticheat.dll just to be sure mine wasn't corrupt or something but it didn't help.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: November 07, 2006, 09:09:22 pm »

It means anticheat wasn't able to re-initialize itself. I have an idea of how to fix this but I'm away from my precious code until the weekend, so expect a fix then.
Logged
Wake
Guest
« Reply #2 on: November 07, 2006, 09:13:41 pm »

Alrighty, thanks.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #3 on: November 10, 2006, 09:26:31 pm »

This will be fixed in next R1Q2 release.

EDIT: Or possibly not. If you could figure out exact steps to reproduce it, it would help. I'd need to know the status of anticheat prior to each connection, ie, did it load, try to load but 'failed to load', etc.
« Last Edit: November 11, 2006, 12:06:29 am by R1CH » Logged
Wake
Guest
« Reply #4 on: November 11, 2006, 06:55:36 pm »

Exact steps:

1. I connect to a server.
2. I use the menu to connect to a different server. (I've tried typing the IP in console but I had the same problem.)
3. My Quake II closes and I get the above error message.

Maybe it's a client-side problem, but I dunno.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #5 on: November 11, 2006, 08:44:21 pm »

Did the anticheat load successfully on the first server?
Logged
Wake
Guest
« Reply #6 on: November 11, 2006, 08:55:41 pm »

Yeah. It was only when I switched servers that it happened.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #7 on: November 11, 2006, 09:31:35 pm »

Can you try downloading the latest .dll from http://antiche.at/, the behaviour you describe seems impossible to happen in the code. Also make sure you are using R1Q2 b6904, and that you show as AC Valid: YES on the first server it connects to.
Logged
Wake
Guest
« Reply #8 on: November 11, 2006, 09:47:51 pm »

All my stuff is up to date. It hasn't happened in a few days. I downloaded new .dlls and that didn't seem to help but maybe I finally got a good one. I can't remember when I downloaded it though...maybe Thursday?
Logged
dk_sn1p3r Guest
Guest
« Reply #9 on: December 12, 2006, 03:03:22 am »

I've had this happen on GHZ's vortex server too when i'm switching charactor files and reconnecting as I posted earlier i've been having issues with bad challanges etc... i'm not sure if the day that this error happened that I was having those same issues tho...
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: Quake II Fatal Error
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines