r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: unexplainable Graphics choppyness with anticheat
Pages: [1]
Print
Author Topic: unexplainable Graphics choppyness with anticheat  (Read 12565 times)
b100d
Member

Posts: 1


« on: January 26, 2008, 09:28:34 am »

I have this problem where i can not use anticheat and play quake 2 without major graphics glitches all the time. It is not related to the changing of the nvidia setting i forget the name of it , because i dont have that option in my nvidia advanved settings. I will start up any of the client's listed for download on the http://antiche.at  website with anticheat enabled and i have these major graphics issues with choppy game play. While r1q1 client would not load anticheat at all i figured out that problem. Somehow the client came installed with it set to compatibility mode for win 98 and me. I simply switched the compatability to win 2000 and the anticheat finally loaded for the first time ever. The problem is that once i enabled the anticheat the only client that i didnt have graphics glitches with was r1q2 because i could not get antichea to work, so once i figured out what that problem was of course i loaded r1q2 and tried to play and now i had the same graphics glitches that i had with all the other clients. So i started up the other clients and typed in aclist because i was under the assumption that anticheat was not working with any of them either, well to my surprise anticheat loaded with them all just fine , but of course they had the graphics glitch problem. So here is where i stand , i can not play quake 2 on any servers you guys are enforcing the anticheat to be used on , so i am basically stuck with a 500 dollar graphics card that i cant use to play the game i love to play because of the anticheat.dll causing horrible problems with my graphics in game, i was talking to quadz and to wallfly on the server about it and they told me to try and rename anticheat.dll to something else. So i     
did and wallah my quake 2 was running flawlessly again, so obviously the problem is in the anticheat.dll as ive tried every other thing i could find on this forum regarding anything possible that could fix it and tried them all and nothing worked at all. So im stuck with you guys enforcing the anticheat.dll to be loaded or i cant play. Quadz and wallfly told me that they were going to stop making it enforced and they did for a day and now they are right back to enforcing it so i am forced to play with this problem which is basically unplayable. I know i keep referring to you guys but really its quadz and wallfly enforcing it sorry R1ch. Anyways please help me R1ch fix this problem so i can play on the servers with it loaded so people will stop accusing me of cheating , im getting tired of that crap. Its the entire reason im required to have it loaded i believe.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #1 on: January 26, 2008, 09:41:39 am »

That's a lot of text, but you missed a few key things like your video card model, driver versions, Windows version, processor and any other information which would help narrow down the problem. And by "glitchyness" are you just referring to lower FPS, or is there actual graphics corruption too? Also, you should turn off any compatibility mode options.
Logged
.B100D
Guest
« Reply #2 on: January 27, 2008, 07:57:21 am »

yeah sorry , i have an evga gecorce 7800 gt slightly over clocked 256mb card.  Bios is 5.70.02.13.6B. I went back to an older driver set and it says version number unknown when i go to properties. I had the same problem with the newest universal drivers as well though. I have windows xp professional with server pack 2. Here are some other system informations :

OS Name   Microsoft Windows XP Professional
Version   5.1.2600 Service Pack 2 Build 2600
OS Manufacturer   Microsoft Corporation
System Name   B100D
System Manufacturer   INTEL_
System Model   D915PBL_
System Type   X86-based PC
Processor   x86 Family 15 Model 3 Stepping 4 GenuineIntel ~2666 Mhz
BIOS Version/Date   Intel Corp. CY91510A.86A.0040.2006.0926.1010, 26/09/2006
SMBIOS Version   2.3
Windows Directory   C:\WINDOWS
System Directory   C:\WINDOWS\system32
Boot Device   \Device\HarddiskVolume1
Hardware Abstraction Layer   Version = "5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)"
User Name   B100D\Derek Blankenship
Time Zone   Eastern Standard Time
Total Physical Memory   1,024.00 MB
Available Physical Memory   583.64 MB
Total Virtual Memory   2.00 GB
Available Virtual Memory   1.96 GB
Page File Space   1.66 GB
Page File   C:\pagefile.sys


and here is some graphics card info and i think the driver version is actually listed because this is directly copied from the system information option on xp :


Name   NVIDIA GeForce 7800 GT
PNP Device ID   PCI\VEN_10DE&DEV_0092&SUBSYS_C5163842&REV_A1\4&29230EF5&0&0008
Adapter Type   GeForce 7800 GT, NVIDIA compatible
Adapter Description   NVIDIA GeForce 7800 GT
Adapter RAM   256.00 MB (268,435,456 bytes)
Installed Drivers   nv4_disp.dll
Driver Version   6.14.10.8198
INF File   oem0.inf (nv4_NV3x section)
Color Planes   1
Color Table Entries   65536
Resolution   1024 x 768 x 120 hertz
Bits/Pixel   16
Memory Address   0xFB000000-0xFDFFFFFF
Memory Address   0xC0000000-0xDFFFFFFF
Memory Address   0xFC000000-0xFCFFFFFF
I/O Port   0x0000AC00-0x0000AC7F
IRQ Channel   IRQ 16
I/O Port   0x000003B0-0x000003BB
I/O Port   0x000003C0-0x000003DF
Memory Address   0xA0000-0xBFFFF
Driver   c:\windows\system32\drivers\nv4_mini.sys (6.14.10.8198, 3.37 MB (3,536,768 bytes), 22/10/2006 14:22)
 

This problem sounds exactly what Quadz was telling me that he had and that you fixed rather quickly and had something to do with api calls were taking longer than expected , but i could not find that on the forums. Hopefully i can do a search or something with topics by his name and find it i just got home . I can wait for an aswer from you too i guess whichever comes first Smiley.
Logged
.B100D
Guest
« Reply #3 on: January 27, 2008, 08:00:35 am »

and sorry to answer your question it looks to be video card choppyness and not lag. Its almost just like flickering pj's if you've ever had that problem which im sure you have sort of like if your downloading a file and playing at the same time. There is no phone jack sign though and i can tell this is a video related problem it looks to be anyways.
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #4 on: January 27, 2008, 01:54:23 pm »

Try running in 32 bit color depth, most cards are not optimized for 16 bit these days.
Logged
.B100D
Guest
« Reply #5 on: January 28, 2008, 08:46:39 am »

switched to 32 bit depth and it still did not fix the problem R1ch ....
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #6 on: January 28, 2008, 12:25:13 pm »

Are you sure you disabled the threaded optimization feature in NVIDIA drivers, if present?
Logged
.B100D
Guest
« Reply #7 on: January 29, 2008, 06:52:08 am »

yeah like i was saying I tried just about everything i could find pretty much relating to anything that sounded like this issue. The option is not there for me.
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  Anticheat  |  Topic: unexplainable Graphics choppyness with anticheat
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines