r1ch.net forums
* Home Help Search Login Register
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  OpenTDM  |  Topic: How to setup an OpenTDM server
Pages: [1]
Print
Author Topic: How to setup an OpenTDM server  (Read 25495 times)
wision
Member

Posts: 237



« on: July 28, 2009, 04:09:23 am »

Many people asked for a guide how to set up an OpenTDM server and those who don't, usually don't set it up properly (missing some anticheat settings and stuff). So here's a guide how to set up an opentdm server with pre-set settings on Q2PRO and R1Q2. (sorry for slow hosting of the config files)

NOTE: Since R1CH himself proposed using Q2PRO if you want to use some advanced features like GTV/MVD, I'm not going to maintain the R1Q2 version of configs anymore.


Q2PRO guide: (tested on: opentdm r173; q2pro r365)

1. Get latest Q2PRO binary and put it in your quake2/ directory.
http://skuller.ath.cx/q2pro/nightly/

2. Get OpenTDM library and put it into quake2/opentdm/ directory.
linux: http://opentdm.com/binaries/unstable/linux/gamei386.so.gz
windows: http://opentdm.com/binaries/unstable/win32/gamex86.zip

3. Download configs and put them into quake2/opentdm/ directory.
http://wision.own.cz/files/server-configs/q2pro_opentdm.zip

4. Modify the configs, so they suit your need. Mostly you need to change these settings:
server1.cfg:
   - net_ip
   - port
   - hostname
   - rcon_password
   - g_admin_password

q2pro_srv.cfg:
   - sv_reserved_password
   - sv_reserved_slots

anticheat.cfg:
   - some settings if you want less strict anticheat policy.. all the variables are explained there

5. If you want to use anticheat on your server, add your server ip to the anticheat servers list here on r1ch.net/forum/. You need to have permission from r1ch to access that part of the forum.
(http://www.r1ch.net/forum/index.php?topic=1392.0)

6. Run your server.
linux example: "./q2proded +set game opentdm +exec server1.cfg +map q2dm1"



R1Q2 guide: (tested on: opentdm r173; r1q2 b7864)

1. Get latest R1Q2 binary and put it in your quake2/ directory. (use r1q2ded not r1q2ded-old! r1q2ded-old works with old mods only)
linux: http://www.r1ch.net/stuff/r1q2/download/r1q2ded.zip
windows: http://www.r1ch.net/stuff/r1q2/download/dedicated.zip

2. Get OpenTDM library and put it into quake2/opentdm/ directory.
linux: http://opentdm.com/binaries/unstable/linux/gamei386.so.gz
windows: http://opentdm.com/binaries/unstable/win32/gamex86.zip

3. Download configs and put them into quake2/opentdm/ directory.
http://wision.own.cz/files/server-configs/r1q2_opentdm.zip

4. Modify the configs, so they suit your need. Mostly you need to change these settings:
server1.cfg:
   - ip
   - port
   - hostname
   - rcon_password
   - g_admin_password

r1q2srv.cfg:
   - sv_connectmessage
   - sv_reserved_password
   - sv_reserved_slots

anticheat.cfg:
   - some settings if you want less strict anticheat policy.. all the variables are explained there

5. If you want to use anticheat on your server, add your server ip to the anticheat servers list here on r1ch.net/forum/. You need to have permission from r1ch to access that part of the forum.
(http://www.r1ch.net/forum/index.php?topic=1392.0)

6. Run your server.
linux example: "./r1q2ded +set game opentdm +exec server1.cfg +map q2dm1"


If you got any questions or suggestions just drop a line here.
Logged
island55
Member

Posts: 8


« Reply #1 on: May 20, 2010, 09:23:08 am »

when i setup all the files in their correct places and exec a *.bat i get this error in the console;


UDP_OpenSocket: 69.242.199.243:27910: can't bind socket: WSAEADRNOTAVAIL
Closing console log.
*****************
FATAL: Couldn't open dedicated server UDP port
*****************
Logged
island55
Member

Posts: 8


« Reply #2 on: May 20, 2010, 09:28:20 am »

OH AND...

when i try to use dedicated.exe instead of q2proded.exe it pops up this error;

"The procedure entry point getaddrinfo could not be located in the dynamic link library WS2_32.dll.

also when i click OK to make the popup box go away... this ERROR still remains in the console;

execing server1.cfg
execing master.cfg
execing anticheat.cfg
execing q2pro_srv.cfg
Unknown command "addgtvhost "217.170.66.83""
Unknown command "addgtvhost "213.79.103.146""
Unknown command "addgtvhost "q2tv.mine.nu""
Unknown command "addgtvhost "skuller.net""
execing q2pro_addstuffcmd.cfg
Unable to load DLL opentdm/gamex86.dll, loading baseq2 DLL.
Loaded Game DLL, version 3
Q2Admin Version 1.17.44
==== InitGame ====
WARNING: opentdm/q2adminlogin.txt could not be found
WARNING: opentdm/q2adminbypass.txt could not be found
Pinging master server 74.86.155.169:27900
ANTICHEAT: Connected to anticheat server!
ANTICHEAT WARNING: You do not have permission to use the anticheat server. Anticheat disabled.
------- Server Initialization -------





other servers work properly with q2proded.exe -OR- dedicated.exe

69.242.199.243:27911
69.242.199.243:27920

is it because i have q2admin 1.17.44 runing also? im confused......
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #3 on: May 20, 2010, 03:26:41 pm »

You need Windows XP or later for the pre-built DLL.
Logged
island55
Member

Posts: 8


« Reply #4 on: May 20, 2010, 04:07:24 pm »

explains everything. windows 2003 server?
Logged
R1CH
Administrator
Member

Posts: 2625



« Reply #5 on: May 20, 2010, 04:12:20 pm »

That should work, make sure you have the latest service pack installed.
Logged
island55
Member

Posts: 8


« Reply #6 on: May 25, 2010, 08:03:56 pm »

okay r1ch, i installed windows2003 server and i got everything installed properly now and this is the error i get now:

ANTICHEAT: Connected to anticheat server!
ANTICHEAT WARNING: You do not have permission to use the anticheat server. Anticheat disabled.


will you please allow me to access the part of the forum to add my IP to the list or can you add it for me...
69.242.199.243:27910
Logged
Pages: [1]
Print
r1ch.net  |  r1ch.net stuff  |  R1Q2  |  OpenTDM  |  Topic: How to setup an OpenTDM server
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines